[Samba] regpatch writing to local registry hive with -F not working (registery-utils 4.0.0~alpha15~git20110124.dfsg1-2ubuntu1)

denis bonnenfant denis.bonnenfant at diderot.org
Sun May 15 09:41:39 MDT 2011

Le dimanche 15 mai 2011 à 10:26 +0200, denis bonnenfant a écrit :
> Le dimanche 15 mai 2011 à 00:28 +0200, Michael Wood a écrit :
> > On 14 May 2011 22:09, Michael Wood <esiotrot at gmail.com> wrote:
> > > On 14 May 2011 19:53, RiCH <rich at richud.com> wrote:
> > >> Hi,
> > >>
> Hi, 
> Two years ago, I worked a bit on this. There was a lot of things to be
> done for full support of regf files patching . My patches mostly worked,
> but I never submitted it because I finally decided to generate .pol
> files with a small python script and appmently it on client side instead
> of patching regf files server-side.
> So I'm going to resurrect my old sources, rebase it on current git, and
> hope it helps... As far as I remember, there was some problems with regf
> format writing, and the registry files generated were sometimes
> corrupted. Investigating it may be quite difficult, as regf format is
> not simple and badly documented. But maybe some work was already done
> yet ? 

I had a look, and the merge is not straightforward. So I have work on it
a little bit. Hopefully, regf code seems  corrected, so I expect some
good news...


More information about the samba-technical mailing list