NULL fsp_name pointer in get_shadow_copy_data

Volker Lendecke Volker.Lendecke at SerNet.DE
Sat May 14 02:43:10 MDT 2011

On Fri, May 13, 2011 at 06:40:00PM -0400, S F wrote:
> I'm maintaining a custom shadow-copy module for samba, and we recently
> tried to transition from 3.5.3 on Fedora 11 to 3.5.8 on Fedora 14, and
> I ran into a problem.
> In my implementation of get_shadow_copy_data, I was accessing the
> share relative name for the file via the file_struct pointer... ie
> fsp->fsp_name->base_name.  This seemed to work fine previously, but
> after trying to upgrade I find that samba is invoking
> get_shadow_copy_data with a NULL pointer in fsp->fs_name.  Anyone have
> any idea whether this is due to a change in Samba code between 3.5.3
> and 3.5.8, or is it more likely due to the change in environment?
> Also, any ideas for a work-around?  Was this incorrect to start with?
> What is the proper way to access the share-relavite name of the target
> file in get_shadow_copy_data?
> Any help would be appreciated!

NULL in fsp_name should not happen. Did you actually
recompile your module with the correct header files? It
might be that we have changed the fields of files_struct, so
that you see the NULL from some other field.


SerNet GmbH, Bahnhofsallee 1b, 37081 Göttingen
phone: +49-551-370000-0, fax: +49-551-370000-9
AG Göttingen, HRB 2816, GF: Dr. Johannes Loxen

More information about the samba-technical mailing list