SMB2 not used with \\server\share but with \\server.domain\share

Christian PERRIER bubulle at
Mon Jun 13 22:38:14 MDT 2011

Quoting Gerhard Wiesinger (lists at
> Ok, I solved the issue. :-)
> Today the server \\server\share didn't work any more but
> \\server.domain\share worked. Also server wasn't listed in net view
> any more.
> After some look I found that nmbd wasn't started because directory
> /var/locks didn't exist:
>   error creating socket directory /var/locks/.nmbd: No such file or directory
> mkdir /var/locks
> service nmb restart
> Then the server was listed in net view again and also worked with
> \\server\share with an WINS server configured on remote network.

Side comment:

You didn't mention if you were using self-compiled samba or distro
packages. We indeed had this problem reported in debian:

The solution is of course either to create the lock directory or (much
better) to use the newly introduced in 3.6.0 "--with-nmbdsocketdir"
option in order to use a directory that's suitable for such files
(/var/run as of now in Debian/Ubuntu and most distros, and /run in the

More information about the samba-technical mailing list