Samba Cross-Compilation Problem

Richard Sharpe realrichardsharpe at
Sun Feb 20 08:36:33 MST 2011

On Fri, Feb 18, 2011 at 8:44 AM, Hitesh Bajaj <hitesh_bajaj24 at> wrote:
> Hi,
> I want to cross-compile samba for arm-linux.
> I have host machine: Red Had Enterprise Edition 5.0 and I am not able to cross compile it.
> I tried 3-4 Versions of samba but in vain.
> Can you guide me through compiling process.Which stable version of samba should i use?Step by step cross compilation process.OR
> If you have binaries or package for samba which i can directly use  at my arm machine.

Well, this worked for me with Samba 3.4.4 or thereabouts around March
2010 and later.

You would be better off to tell us:

1. What tool chain you are using?
2. What version of Samba you are trying to cross compile?
3. What specific problem you are seeing?

It really was a matter of simply making sure that the bin directory
for the tool chain was in my path, running configure with the correct
arg to select the tool chain and then running make.

Richard Sharpe

More information about the samba-technical mailing list