Joining 2008 R2 Domain fails with samba4

Andrew Bartlett abartlet at
Mon Feb 14 02:19:21 MST 2011

On Wed, 2011-01-26 at 02:15 -0500, Eric Painley wrote:
> Hello,
> I have a Windows Server 2008 R2 domain (running on 2003 native mode AD) with Exchange 2010 SP1. I would like to add a samba4 domain controller to my domain. I have the latest (as of 1/25/11) git of samba-master but I have been getting some wierd errors when trying to join it. At first I was getting an NT_STATUS_INTERNAL_ERROR then I saw a previous post by someone with the exact same problem at So I applied Kamen's patch ( and I was able to get much farther this time.

(error due to msExchBridgeheadedLocalConnectorsDNBL being single valued,
by having multiple values)

> Note that this is the EXACT SAME ERROR as the poster had in Where he goes on to say that using the "net vampire" tool give a more verbose error report. However I don't have the net vampire tool anymore as this is a later git and it has apparently been removed and replaced with "samba-tool join".
> Sorry for posting all those links for from the old post but I believe our problems are very similar.

Eric and Stephan, 

I've worked with tridge to add a workaround for what we think is a
broken schema from Microsoft.  Our guess is that the single-value checks
are not applied to backlinks, and so we now skip them in Samba4.

The fix is in master after a6af1efb422e10bb66524fdceb2babaa8ca1bffe, can
you try again with current master if you are able?  It would be good to
confirm that this is fixed if at all possible. 


Andrew Bartlett

Andrew Bartlett                      
Authentication Developer, Samba Team 
Samba Developer, Cisco Inc.

More information about the samba-technical mailing list