unable to join ADS "network path was not found"

David Lindauer david at otlayi.com
Fri Feb 11 17:15:26 MST 2011

We've got Samba4 running well serving shares and handling AD logins.  
When we're trying to connect 2 new Windows 7 PCs to the domain, which 
has worked previously and the rest of the computers are connected, it 
fails with "network path was not found".

I have ran it through Wireshark  shows 2 x SMB_NETLOGON requests to the 
server, then 3 x responses from the server showing "SAM Active Directory 
Response - user unknown", then 2 x more logon requests, and then 3 x 
"Active Directory Response to SAM LOGON request".  It takes a minute to 
come back with the error, the login is valid and I've tried a few 
different ones.

Looking at samba interactively on a high debugging level, I see several 
entries right around the time it fails:

Received dgram packet of length 241 from
netlogon request to MYDOMAIN<1c> from
gendb_search_v: CN=Sites,CN=Configuration,DC=mydomain,DC=com 
(objectClass=site) -> 1
added interface ip= nmask=
added interface ip= nmask=

I tried reverting several smb.conf settings back, none of the changes 
seems to have any impact on devices being able to join the active directory.

David Lindauer
Director of Operations
Otlay Interactive

More information about the samba-technical mailing list