Changing DNS domain/SOA values with samba-tool?

Adam Tauno Williams awilliam at
Thu Dec 22 13:09:25 MST 2011

On Thu, 2011-12-22 at 20:48 +0100, Enrico Ehrhardt wrote:
> To put it simple: You cannot do that. The "." is not just a name or an
> entry. It's a zone, the so called root zone.
> This may by the right place to read:

I'm aware that it is a zone.  My question is what is the samba-tool
syntax to change the value of the root A record for the zone; which can
be queried but _apparently_ can't be modified.  Since I can't change
this value - Kerberos won't work.

I've even tried
hacking .../lib64/python2.7/site-packages/samba/netcmd/ to pass
either '' or None into the dns_record_match call.

The problem is that unlike -
  Name=barbel, Records=1, Children=0
    A: (flags=f0, serial=3, ttl=900)
 - which has a name and can be updated..  The root records in the zone
don't have a name -
  Name=, Records=3, Children=0
    SOA: serial=8, refresh=900, retry=600, expire=86400,, (flags=600000f0,
serial=8, ttl=3600)
    NS: (flags=600000f0, serial=1, ttl=900)
    A: (flags=600000f0, serial=1, ttl=900)
 - and thus can't be modified with the same syntax.

>         samba-tool dns query @ ALL
>         Password for [administrator at MICORE.US]: **************8
>          Name=, Records=3, Children=0
>            SOA: serial=5, refresh=900, retry=600, expire=86400,
>         (flags=600000f0,
>         serial=5, ttl=3600)
>            NS: (flags=600000f0, serial=1, ttl=900)
>         *** A: (flags=600000f0, serial=1, ttl=900)
>         *****
>          Name=_msdcs, Records=0, Children=0
>          Name=_sites, Records=0, Children=1
>          Name=_tcp, Records=0, Children=4
>          Name=_udp, Records=0, Children=2
>          Name=barbel, Records=1, Children=0
>            A: (flags=f0, serial=3, ttl=900)
>          Name=DomainDnsZones, Records=0, Children=2
>          Name=ForestDnsZones, Records=0, Children=2
>         But what is the value for <name> in "samba-tool dns update
> <name> A" in order to
>         modify that entry.  I've tried "", ".", "@"....  none of which
>         map to a record in the LDB, thus yielding -
>         ERROR(runtime): uncaught exception - (9701,

More information about the samba-technical mailing list