Inconsistent naming of vfs_read in the VFS Function pointer structure ...
realrichardsharpe at gmail.com
Fri Dec 2 05:15:13 MST 2011
On Fri, Dec 2, 2011 at 3:02 AM, Andrew Bartlett <abartlet at samba.org> wrote:
> On Mon, 2011-11-28 at 13:02 -0800, Jeremy Allison wrote:
>> On Sat, Nov 26, 2011 at 01:19:10PM -0800, Richard Sharpe wrote:
>> > Hi folks,
>> > I came across this:
>> > /* File operations */
>> > .open_fn = vfswrap_open,
>> > .create_file = vfswrap_create_file,
>> > .close_fn = vfswrap_close,
>> > .vfs_read = vfswrap_read,
>> > .pread = vfswrap_pread,
>> > .write = vfswrap_write,
>> > .pwrite = vfswrap_pwrite,
>> > .lseek = vfswrap_lseek,
>> > Is there any reason that it is vfs_read and not just read?
>> We should probably do a global rename to _fn for 4.0.0,
>> to have consistent naming. It breaks all outside tree
>> libraries though.
>> Maybe out-of-tree folks can respond ? Would this be
>> ok for 4.0.0 ?
> While this would be a bigger change, we already changed a number of
> other things for out of tree modules (we even changed the init function
> name!), so it seems like a good opportunity.
OK, let me raise a bug in bugzilla then. That would seem to be the first step.
More information about the samba-technical