Help with Samba4 as a DC

Scott Jordahl scott at
Sun Aug 21 14:18:20 MDT 2011

Thanks Marco:

I did watch the videos when they first came out. I have existing setups 
of Samba4 acting as a PDC with no problems. Where I am struggling is 
trying to get Samba4 to act as a BDC. I have folder structures on the 
Samba4 server requiring restrictive ownerships for access. I am able to 
set the access via the Win2k3 server. When I go to the Ubuntu server 
with Samba4, all the ownerships show as "30000xx"  (where xx is a unique 
identifier), which of course, is how it is suppose to be. However, I am 
not able to "see" who the owner is by name. If I try to do a 
"/usr/local/samba/bin/wbinfo -u", it hangs, finally times out, and the 
RPC part of the samba process dies (or it could be just one of the spawn 
child processes dies). The same thing is true if I try using any wbinfo 

When the RPC part of samba process dies (or the child), users can still 
access file shares, but when you go to make a chance to file 
owership/access in the windows environment, you get the message: "The 
program cannot open the required dialog box because it cannot determine 
whether the computer named "server01" is joined to a domain. Close this 
message and try again". When you close that pop-up, you get another 
pop-up with: "Unable to display the user selection dialog. The RPC 
server is unavailable.". Closing the messages and trying again has no 
effect of course. You must restart the samba process(es). A user not 
previously logged in will not be able to log onto the domain while samba 
is in the broken state.

If I run samba in single instance mode (samba -i -M single) and run 
wbinfo -u, wbinfo times out and the samba process dies with: "PANIC: 
internal error, Aborted". BTW - Before running the wbinfo command, I 
have many successful "Replicated" debug messages displayed, so things 
are working fine up to this point.

I've used alpha11 to alpha16 to the GIT from 2 weeks ago with the same 
issue. I've also tried re-joining to the domain using a new 
/usr/local/samba filesystem with no change (except all the UIDs changed 
and I had to re-map all the user files: 500Gb worth).

-- Scott

On 08/21/2011 11:13 AM, Marco Rojas wrote:
> Watch this video:
> I have struggled with Ubuntu 10.04 so I would advice to use Debian or 
> Ubuntu 11.04.
> On Sun, Aug 21, 2011 at 1:02 PM, Scott Jordahl <scott at 
> <mailto:scott at>> wrote:
>     Really??  No one can help me out here? Please at least answer the
>     question regarding DNS being  required on the secondary DC
>     (Samba4). I'll go from there and will provide the additional
>     documentation for the "Samba4 as a DC". Now, if DNS is NOT
>     mandatory, then I have some bug reporting to do. Actually, I'll
>     need to submit a bug regardless. The samba process should not
>     PANIC but exit gracefully or generate a reasonable error message
>     if DNS is missing.
>     -- Scott
>         I'm confused on how the "Samba4 as a DC" setup is suppose to be
>         configured. I have an existing Win2k3 server acting as the main AD
>         (along with DHCP+DNS), I have installed samba4 alpha16 on a Ubuntu
>         10.04LTS x64 based system. Since the Win2k3 system is
>         providing DNS, I
>         figured I didn't need to worry about DNS on the Ubuntu system.
>         This,
>         apparently, is not the case as I get PANICS in talloc any time
>         I try to
>         do a wbinfo and samba's RPC dies. Actually, samba's RPC dies
>         randomly
>         without notice and things "kind-of" work (eg - file share are
>         still
>         accessible, but you cannot modify file/folder security settings).
>         Following the instructions on "Samba4/HOWTO/Join a domain as a
>         DC", none
>         of the needed bind9 component are generated (eg -  dns.keytab,
>         named.conf, etc). I'm not clear on how to generate these from
>         scratch
>         and what the named.conf file should look like on the Ubuntu
>         server. Any
>         help would be appreciated. Of course, I'm hoping that this is
>         what the
>         issue is and that I don't have some other problem going on.
>         Thanks,
>         -- Scott
> -- 
> Live free, live Linux!

More information about the samba-technical mailing list