[SOLVED SORT OF] Re: adding principals in S4 to controller account

Trever L. Adams trever.adams at gmail.com
Fri Aug 19 16:18:05 MDT 2011

On 08/19/2011 10:28 AM, Ted Salmon wrote:
> Just Wondering, and I could be completely off here as krb has been
> socking it to me, but have you tried to add/list SPN's via samba-tool
> spn list <username>?

No, but I realized after a bit of much needed downtime that the fact I
have an nfs/FILESERVER ticket granted that S4 is not the problem. After
digging around I found out that I need reverse DNS working as
rpc.svcgssd on the server is not passed a principal name with the
principal, but constructs it from reverse DNS.

Unfortunately this is going to be a bit of a pain since net ads dns
register (Samba 3.5.8) dos NOT work with S4. I am going to have to
figure out a way of doing this.

Thank you,
"Those willing to give up a little liberty for a little security deserve
neither security nor liberty." -- Benjamin Franklin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 261 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba-technical/attachments/20110819/1cca90c1/attachment.pgp>

More information about the samba-technical mailing list