ldbdel error

Bob Miller bob at computerisms.ca
Sat Aug 13 12:56:54 MDT 2011


Not sure if this belongs here or on the main mailing list.  I apologize
if it should be on the other.

I used oLschema2ldif to (mostly) convert a schema and imported it into
ldb under CN=Schema,CN=Configuration,DC=computerisms,DC=ca.  A few of
the entries failed to go in, so in experimenting I added a dn with an
incomplete list of attributes, figuring I would delete it and add again
till I have it right or find why it isn't working.  

When I try to delete the entry using ldbdel it gives an error:

./ldbdel -H ldap://localhost --realm=computerisms.ca
-Uadministrator at computerisms.ca

delete of
'CN=qmailUser,CN=Schema,CN=Configuration,DC=computerisms,DC=ca' failed -
(Unwilling to perform) LDAP error 53 LDAP_UNWILLING_TO_PERFORM -
<00002035: Unwilling to perform - No Deleted Objects container for DN
CN=qmailUser,CN=Schema,CN=Configuration,DC=computerisms,DC=ca> <>

I tried using ldbmodify and an ldif file to delete the entry, too, but
got the same error.

I found a few pages that indicate the error means I am trying to do
something that is forbidden, whether it be because of credentials,
connection restrictions, or a violation against the attribute or server

I have been searching on this for a while, but found nothing yet
indicating a way forward.  it seems my ldb is populated with entries I
cannot get rid of.  Given that I have correct credentials and there
should be no restrictions on a connection from localhost, I must be
doing something else that ldb doesn't like.  any clues how I might

Bob Miller
bob at computerisms.ca
Network, Internet, Server,
and Open Source Solutions

More information about the samba-technical mailing list