SID allocation from a W2K3 RID master

Cam Thompson camthompson at
Tue Sep 21 19:27:51 MDT 2010

It worked!

Now I can directly add a user to my S4 secondary DC with 
w2k master dc that was upgraded from w2k functional role. 
 This server had many years of production history and has 
been interesting.  I want to thank the entire Samba dev 
team for their help and patience as we have struggled with 
getting this problem solved.  Not much longer and we'll 
have our domain running entirely on Samba4.

For those who are interested, there is a pretty detailed 
wiki page on the samba page:

I will still continue to update the wiki and work the 
Samba team as much as I have been, maybe more :)  Just 
thought this would be a good opportunity to express my 
gratitude for everyone's amazing work.

-Cam Thompson (plaerzen)
System Administrator
Tundra Engineering Associates

On Tue, 21 Sep 2010 13:47:42 -0600
  "Matthieu Patou" <mat at> wrote:
>  Hi Cam,
> Yesterday tridge and anatoly nailed down the pb that you 
>had on your s4 
> server joined to a W2K3 DC as we were able to reproduce 
>it on my computer.
> Patches have landed in the master tree of samba, you 
>should give it a 
> try and be now able to create users against the s4 DC.
> Let us know the final result.
> Cheers.
> Matthieu.
> -- 
> Matthieu Patou
> Samba Team

More information about the samba-technical mailing list