Replication to a Windows 2008 R2 fails

Andrew Bartlett abartlet at
Thu Sep 16 19:09:58 MDT 2010

On Thu, 2010-09-16 at 19:55 -0500, David Gonzalez wrote:
> Well Andrew,
> Thank you very much for you insights on this topic, I appreciate your time
> and that from other samba members.
> As I told you I've checked the latest git and installed it and Oh!, surprise
> dynamic updates are working fine securely as expected, nice job those MS
> guys will be very pleased with the progress  that samba is making.
> Also I tried joinig my W2k8 machine and it successfully does it, but the
> DRS_ACCESS_DENIED error keeps showing up, I'm trying to debug that so I can
> see what is going on.
> Also I tried joining another Samba DC with net vampire it looked good and
> it's replicating fine, but as I asked on a previous message, when I start
> samba or samba_dnsupdate I see that it's trying to update service names on
> itself, I'd like to make that script point to my DNS server at
> where also samba is running.

You should ensure your resolv.conf points at the other machine, and you
never set up a BIND on more than one machine.  (Note that we have not
tested or prepared for bind slaves). 

You will note that the provision does prepare an example DNS
configuration on all installations of Samba4.  I'll see about
suppressing that when we are in the vampire case, as clearly then
someone else already holds the DNS role. 

Andrew Bartlett
Andrew Bartlett                      
Authentication Developer, Samba Team 
Samba Developer, Cisco Inc.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 190 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the samba-technical mailing list