errors with last git

Maurizio Marini Gmail marini.maurizio at
Thu Sep 9 02:59:21 MDT 2010

On Thu, Sep 9, 2010 at 10:42 AM, Andrew Bartlett <abartlet at> wrote:
> On Thu, 2010-09-09 at 10:32 +0200, Maurizio Marini Gmail wrote:
>> On Wed, Sep 8, 2010 at 11:25 PM, Andrew Bartlett <abartlet at> wrote:
>> >
>> Dear Andrew
>> first of all thnx for help
>> I am investigating at he moment:
>> with lenny 5.0.6 my installation is working well
>> than i decided to dist-upgrade to squeeze;
>> thnx again for your attention to us  and for appreciating our efforts
>> to help you to debug samba4 :)
> Are you running Samba4 from GIT, or debian packages?

/usr/local/samba/sbin/samba --version
Version 4.0.0alpha12-GIT-aa830cd

> Have you run upgradeprovision (probably with --full) since the upgrade?
yes i did, but with no success
same errors

> Samba4 is not backward compatible with it's database - you must
> explicitly upgrade your provision, or start it from scratch.
i haven't upgraded samba, only debian from lenny to squueze

these are the steps to reproduce the issue:

i took a debian lenny 5.0.6 with samba Version 4.0.0alpha12-GIT-aa830cd
samba4 works nice
i changed lenny with squeeze into /etc/apt/sources.list
i installed kernel first to avoid udev pains
than apt-get dist-upgrade
after dist-upgrade i run
/usr/local/samba/sbin/samba -i -M single -d 6
i got errors ad my previuous post
so i did:

$ cd samba-master/source4
$ ./
$ ./configure.developer
$ make

to refresh samba4 binaries with squeeze libraries
but still error
i tru to  upgradeprovision --full
no success, still the same error

is there a way to rescue previous provision or is better to do a fresh one?

rm /usr/local/samba/etc/smb.conf
./setup/provision --domain=SAMDOM
--adminpass=SOMEPASSWORD --server-role='domain controller'

Maurizio Marini

More information about the samba-technical mailing list