help with net vampire error

Aaron Solochek aarons-samba at
Sat Oct 16 10:15:12 MDT 2010

On 10/16/2010 08:50 AM, Jelmer Vernooij wrote:
> On Sat, 2010-10-16 at 02:01 -0400, Aaron Solochek wrote:
>> On 10/15/2010 05:12 PM, Jelmer Vernooij wrote:
>>> Hi Kamen,
>>> On Sat, 2010-10-16 at 00:05 +0300, Kamen Mazdrashki wrote:
>>>> On Fri, Oct 15, 2010 at 23:47, Aaron Solochek <aarons-samba at> wrote:
>>>>> On 10/15/2010 04:32 PM, Kamen Mazdrashki wrote:
>>>>>> On Fri, Oct 15, 2010 at 22:52, Aaron Solochek <aarons-samba at> wrote:
>>>>>>> It's a lot of output, so I've attached it.
>>>>>> It seems you already have entries for your new BAR machine in db.
>>>>>> Could you try "unvampire" (sort of) and then try again with 'net vampire'
>>>>>> and big 'log level'
>>>>>> You can 'unvampire' quick&dirty with following mini-script:
>>>>>> bin/ldbdel -H st/dc/private/sam.ldb
>>>>>> "CN=LOCALVAMPIREDC,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=foo,DC=com"
>>>>>> -r
>>>>>> bin/ldbdel -H st/dc/private/sam.ldb "CN=LOCALVAMPIREDC,OU=Domain
>>>>>> Controllers,DC=foo,DC=com" -r
>>>>>> bin/ldbdel -H st/dc/private/sam.ldb
>>>>>> "CN=LOCALVAMPIREDC,CN=Computers,DC=foo,DC=com" -r
>>>>> There was also a problem on the primary DC where all the ldb stuff was looking
>>>>> for modules in /usr/modules/ldb while they were installed via the debs in
>>>>> /usr/lib/ldb
>>>> Hm, that's interesting.
>>>> I don't know who the debs packagers is, but I am including Jelmer in the loop.
>>>> (Jelmer, just for your reference if you are the one that made debs.
>>>>  If not, then sorry for the noise :) )
>>> That's correct, I'm the Samba 4 packager for Debian and Ubuntu. 
>>> Aaron, things are working fine here - what version of the packages were
>>> you using?
>> 4.0.0~alpha14~bzr14327~ppa162+179~maverick1
>> I had a build from source on that machine at one point in /usr/local/samba4, but
>> I moved that out of the way before installing the debs.
> Ah, so that's fairly recent. What version of ldb ? 

Sorry, I checked the wrong computer.  On the DC, where I ran that command, I was
samba4 4.0.0~alpha14~bzr13916~ppa160+170~maverick1 and
libldb0 1:0.9.14~git20100928-1

I attempted to upgrade everything, which succeeded on everything but the samba4
package.  It failed because I had a rogue from some earlier non-deb based
installation.  I killed that, but samba4 still failed to upgrade because of
undefined symbols since there was now a version mismatch between those current
ldb libraries and the older samba4 libraries I was trying to upgrade.  I
manually unpacked the deb and installed the package, then tried to install the
deb again (so my package database was sane) and got this:

 * Stopping Samba 4 daemon samba
                                        [ OK ]
Found 2 domain controllers, for the moment upgradeprovisionis not able to handle
upgrade on domain with more than one DC, please demote the other(s) DC(s) before
Sanity checks for the upgrade fails, checks messages and correct them before
rerunning upgradeprovision
A transaction is still active in ldb context [0x1709bb0] on
A transaction is still active in ldb context [0x2e665d0] on
A transaction is still active in ldb context [0x1d0d9c0] on
A transaction is still active in ldb context [0x2912c60] on
dpkg: error processing

Are the active transaction messages expected for the 2 DC situation?  Also, how
do I demote and then re-promote the other DC in order to complete this upgrade
and get my system to a sane state?


More information about the samba-technical mailing list