Broken box was ./samba-tool vampire broken?

Magnus Benngård magnus.b at
Sat Nov 6 09:30:13 MDT 2010

Yay, did manage to solve my problem!
Did remember that it was an old box that has gone from etch to sarge to 

I did purge some installed packages and then the "vampire" worked. :)
My guess is that it was "winbind" that blocked me, but I am not sure.
But what the he.., the box is now part of the domain! :)


I guess this not actuallay a Samba4 question any more, but I would glad if
any smarter than me can help me.
Had some time over today so i "went back" to my old box that couldn't
Yesterday I "vampired" another box and did write up exactly what I did so i
wouldn't forget any step.
Did a "rm -r /usr/src/samba-master and rm -r /usr/local/samba" and started
from sctrach.

aptitude update
aptitude full-upgrade
apt-get install build-essential libattr1-dev libblkid-dev libgnutls-dev
libreadline5-dev python-dev autoconf python-dnspython gdb lpr git-core bind9
aptitude psmisc krb5-user ntp dnsutils

vi /etc/ntp.conf
server iburst dynamic
server iburst dynamic

cd /usr/src
git clone git:// samba-master
cd samba-master/source4
make quicktest
make install
cd /usr/local/samba/bin/
./samba-tool vampire -Uadministrator --force
(saw that I was supposed to use "join" but was unsure about the syntax)
Password for [INPUTINTERIOR.SE\administrator]:


Password for administrator at INPUTINTERIOR.SE:
Warning: Your password will expire in 25 days on Thu 02 Dec 2010 06:48:32 AM

Then I tried another box with the same "run", "vampired" without any problem
Right know I have "vampired" 7 boxes with the same "run" all with real

It must be something in the box that that is broken but i cant figure out
what. :(

Hi Magnus,

I run local replication/vampire buildfarm by the hour with Samba4,
Win2003, Win2008(32/64bit) and dcpromo on Win2008. I have not seen any
problems and all environments work fine.

I have just noticed changes in samba-tool vampire output screen log
messages. Other than this both Andrews are doing some Ldb library move
that triggers initialization errors during vampire.

Hope this hepls.

On 11/3/10 11:56 AM, Magnus Benngård wrote:
> Have a “master” box, up and running.
> Did setup a new box either on Oktober 30 or 31 
> with git clone git:// samba-master and
> Did all the normal dns stuff and then, ./samba-tool vampire 
> -Uadministrator started samba, 
> np.
> Created some users on, ofc they “showed up” on 
> after some minutes.
> It worked so well so i did setup a third box, 
> today, same build procedure but when i did:
> ./samba-tool vampire 
> -Uadministrator
> Password for [INPUTINTERIOR.SE\administrator]:
> Aborted
> Ofc i could have done something different, but is it possible that there 
> have been some code changes the last days?
> Or can any give me an idea where I should look for config/build faults?
> /Magnus

More information about the samba-technical mailing list