s4: renaming lp_ => conf_

tridge at samba.org tridge at samba.org
Tue May 18 04:00:12 MDT 2010

Hi Metze,

 > at SambaXP we discussed to rename the lp_* functions in s4 to
 > conf_* to avoid symbol conflists with s3.


 > If someone starts to do this, please don't use conf_* as prefix,
 > I think something like lparm_* or lp_ctx_* would be a better name.
 > This will less likely produce conflicts with external headers/libraries.

true. Very likely lp_ wasn't a good prefix to choose either :-)

I think lparm_ or maybe lpcfg_ would be good

The idea is to also keep the lp_ functions in the merged loadparm
code, but they would use a global context.

Cheers, Tridge

More information about the samba-technical mailing list