Dan Rudder dan at
Wed May 12 05:23:57 MDT 2010

Thank you all for getting back to me!!!!!
I filed the report because a dialog box suggested I do so.

I do not consider myself much more than a newbie when it comes to the 
guts of Linux. I have been using desktop distros ( Puppy to save old 
machines that I give to people to use who cannot afford a new computer, 
PCLINUXOS, Fedora (my only commercial application),and various Ubuntu 
versions including Mint)  for 5 years. I usually can fix most problems 
that I run into thanks to Google and my experiences with MS os's and 

I would like to repeat that my problem is not unique to me. How many, I 
have no way of knowing, just that it appears to be an issue on the forums.

I had a fully updated machine according to package manager. I did a 
distro upgrade with apt-get. Samba did not run after upgrade. I tried to 
start Samba and would get a message to install Samba4, which I did 
several times. Some times it would work until I restarted the machine 
and then quit or sometimes it would not work at all. Only after 
completely removing Samba and then reinstalling did it work. Even then, 
it would not connect to my MS Workgroup because it was not named 
"WORKGROUP", until I added my workgroup.

I use and give out a lot of livecd's for people to try Linux and to 
rescue broken MS systems. Most people are going to say that if it does 
not work out of the box (like it use to work), they are not going to use it.

Thank you for your time,

On 05/12/2010 03:42 AM, Jelmer Vernooij wrote:
> Hi Sassy,
> On Tue, 2010-05-11 at 17:32 -0700, Sassy Natan wrote:
>> Well, I'm sorry this happened.
>> I will try to explain:
>> Ubuntu 9.10 was released on 29 October 2009 and come by default with
>> samba 3.4.0-3ubuntu5 package. This is Samba3 Version branch, which is
>> different from samba4.
>> Now if u did packages update during the time u had ubuntu 9.10, then,
>> u might end up with 3.4.0-3ubuntu5.6 version, which are some security
>> fixes and such.
>> Now, Ubuntu 10.4 ship with Samba4 and Samba3 as the SMB/CIFS provider
>> protocol, so if you update the samba pkg from 3 to 4, just because you
>> was thinking this is kind of upgrade, then it might got conf files out
>> of control.
>> Can u please send us the /etc/samba or /etc/smb files?
>> If there are being kept as for the samba3 files, we might bring your
>> old samba3 server up and running.
>> Jelmer, How can we prevent this for happening?
>> Maybe we should do some Samba4 Notification before installing this?
> I don't think there is much we can do here. The samba4 package
> descriptions already mention it is experimental. It's also already a
> separate package, you don't get it magically when you upgrade, you
> have to install it explicitly.
> We're currently invoking the upgrade scripts to upgrade the s3
> configuration to s4, though that script needs some extra work.
> Cheers,
> Jelmer
>> Can u think about some other way this could be happening?
>> Sassy
>> On Tue, May 11, 2010 at 5:00 PM, Dan Rudder<dan at>  wrote:
>>> -------- Original Message --------
>>> Subject: Re: Broken
>>> Date: Tue, 11 May 2010 19:59:47 -0400
>>> From: Dan Rudder<dan at>
>>> To: Andrew Bartlett<abartlet at>
>>> I am sorry, I do not know how to get the info you want.
>>> Ubuntu 9.10 was running fine. I upgrade to 10.04 and lost connectivity
>>> to my Windows network and stand alone networked printers.
>>> A lot of other users are having this or a similar problem. Just look at
>>> the Ubuntu forums.
>>> As far as testing goes, I tried both the beta and final release on the
>>> live cd with no problems. I did do an in-place upgrade rather than a
>>> fresh install.
>>> I reinstall Samaba several times through both package manager and
>>> apt-get with no luck. I finally went to package manager and completely
>>> removed all references to Samba and the did a reinstall. It did start up
>>> and run. It only showed the default "WORKGroup" and not automatically my
>>> Windows workgroup. Normally my group had been showing up automatically.
>>> Hope this helps,
>>> Dan Rudder
>>> On 05/11/2010 07:38 PM, Andrew Bartlett wrote:
>>>> On Tue, 2010-05-11 at 16:07 -0400, Dan Rudder wrote:
>>>>> Samba4 upgrade broke my network!!!!!!!!!!!
>>>>> It does not start!
>>>> I'm sorry, I'll need a few more clues than that.
>>>> Can you tell me what version of samba4 you were running, what version
>>>> you are running now, what arguments you supplied to upgradeprovision,
>>>> and what errors you got when you inspected the logs.  (perhaps up the
>>>> log level to log level 5 for a start).
>>>> Also, what steps did you take to test the upgrade?
>>>> Thanks,
>>>> Andrew Bartlett

More information about the samba-technical mailing list