Corrupted GPO

George Lazar at
Tue Jun 29 03:38:40 MDT 2010

Hi Wilco,

I'm using dsa.msc with GPMC from an Windows XP machine. Now the errors that
I have once I open GPMC:
"The system cannot open the device or file specified"

click ok and and under domain at Group Policy Objects I don't have any
policy anymore. If I want to create a new one I got: 
"The specified server cannot perform the requested operation"
 and right after that:
"The directory service is unavailable"
 and then I have to reboot the server in order to be able to authenticate
against the LDAP.

Sometimes there is no necessary a reboot and I can see GPOs linked to the
OUs and are working but I can't create a new one and I don't see them
anymore on the GPO list.

I have tried to manually delete the folder with the last policy that I have
created but the situation is the same, even after a reboot.

I'm really desperate..


Wilco Baan Hofman wrote:
> Hi George,
> Op maandag 28-06-2010 om 22:46 uur [tijdzone -0700], schreef George
> Lazar:
>> Hi,
>> I'm using Samba 4 alpha12 from about 6 months in a production environment
>> with ~ 150 users. Yesterday I have created an new GPO and when I was
>> adding
>> users on the security section I was started to receive error messages
>> like:
>> "There is not enough space on the disk", "Cannot find object", etc.
>> This turned in to an corrupted GPO, basically now I can't see the
>> existing
>> GPOs and I can't delete the new created GPO...
> How did you try this? From the GPMC? You might try manually deleting the
> directory from sysvol and then try deleting the GPO through the GPMC.
>> I need a way similar with: dcgpofix /ignoreschema (this can be runed only
>> from Windows 2003)
>> to fix the GPOs.
> As far as I can tell, this tool only reads the security settings from a
> DC and resets these in the Domain Controller Policy. In the case of
> samba4, that won't really do anything useful unless that is the GPO you
> have a problem with.
>> I didn't tried (yet) to add an Windows 2003 on the domain and try from
>> there.
> Replication does not currently replicate the sysvol directory, so in
> this case, this won't help you.
> --
> Wilco Baan Hofman

View this message in context:
Sent from the Samba - samba-technical mailing list archive at

More information about the samba-technical mailing list