Samba4::Adding domain user with blank password?

Matthias Dieter Wallnöfer mdw at
Thu Dec 2 01:57:18 MST 2010

Hi Andrew,

after doing some verification I've noticed that this has been broken 
some time ago. I'm working on a fix.


Andrew Shinkarchuck wrote:
> Hi there!
> i have samba4.0.0alpha14-GIT-56290d0 at debian5 and 2003 server domain
> controller setupped like in Samba4/HOWTO. also i have test winxp computer
> succesfully joined to this domain.
> i have logged on as domain administrator and tried to add user into domain
> with WinServSP2 Administration Toolkit Pack "AD users and computers" tool.
> i tried to add user "student" with no password but receieved error
> messagebox
> ------------------------------------------------------------------------------
> |Active Directory                                                      |
> ------------------------------------------------------------------------------
> |Windows cant change password for student because:|
> | A device attached to the system is not functioning   |
> -------------------------------------------------------------------------------
> Can someone explain me, why blank password are not allowed in curent samba4
> version?
> Thanks!

More information about the samba-technical mailing list