[IPA] Attribute Linking and Indexing

Matthias Dieter Wallnöfer mdw at samba.org
Fri Oct 9 01:18:04 MDT 2009

Hi Endi,

your work looks really good but In addition to metze's response I would 
like to add
- It's possible for you to do a check against a recent revision (only to 
make sure that it applies - maybe some changes from us done in the 
meantime affect yours and then we have problems on merge)
- Memory corruption: to be honest I would like to see it fixed where it 
does occur. That's always the better approach than trying to "bypass" it 
in certain functions (which makes them more complex than needed). In 
addition ldb* files belong to the LDB library which itself should be as 
API/ABI stable as possible (since it is in use also by other software) 
and therefore changes should be avoided when there doesn't exist a good 
reason (e.g. bugfixing, memory leaks, wrong error result...).
Regarding your problem: Did you try a run under gdb or valgrind which 
maybe helps to find out the bug? Or give us advices how you reproduced this.


Stefan (metze) Metzmacher schrieb:
> Hi Endi,
>> Attached are the patch that I wanted to submit and the test results.
>> It's supposed to fix some issues including bind credential and
>> attribute linking configuration.
>> The problem is there seems to be a memory corruption that I haven't
>> managed to pinpoint, but I was able to get around it by checking for
>> a null pointer (see the ldb_msg.c in the patch). The tests result is
>> also inconsistent from one run to another (see attached files). What
>> is the strategy for debugging memory corruption?
>> This patch was created against an older revision from Sep 15:
>> f410d23185f5c81dbc111285ea0ba9daf5fc111d
>> I used this revision because it's the most stable one that I found
>> so far.
>> I tried using the latest revision in master branch but it failed
>> to compile (implicit declaration of function 'isprint' in torture/
>> smb2/streams.c).
>> I also tried going back to a revision from Oct 7:
>> d29409c1523b9d7ca9b3a7400bd9c94641decc46
>> It compiled successfully, but the OpenLDAP test failed even before
>> I applied my patch on it. It seems that the provisioning tool is
>> generating some attribute values that are rejected by OpenLDAP.
>> Is there anybody else testing OpenLDAP using the latest revision?
>> I haven't got enough information to show you about the new issues,
>> but how should I proceed from here? Should I continue debugging the
>> latest revision and submit a single patch that fixes all of these
>> issues? Or should I look for the newest revision that is stable
>> enough and create a patch based on it? Or should I fix the issues
>> separate issues, i.e. leave the attached patch as is and fix the
>> new issues in a separate patch?
> just a little comment on the patch,
> 1. please change // comments to /* */
> 2. split the patch into multiple patches one for each problem
> metze

More information about the samba-technical mailing list