Matthieu Patou mat+Informatique.Samba at matws.net
Sun Nov 29 02:07:44 MST 2009

On 29/11/2009 10:02, Andrew Bartlett wrote:
> On Fri, 2009-11-27 at 20:23 +0300, Matthieu Patou wrote:
>> Andrew B,
>> For a reason that I can't explain update_machine_account_password do not
>> work properly to update the supplementalCredentials and that's why using
>> smbclient for s4 against the updated tridge provision is failing
>> (because it's provision use w2K8 domain level and everything is done so
>> that aes is activated).
>> I tried several trick and failed so a guru of this stuff is required.
>> Note that setting the password with sbin/setpassword but things back in
>> order (well once the kvno has been modified to put secrets.ldb and
>> sam.ldb in sync)
>> Could you have a look ?
> The easy answer it to simply use the same code as setpassword, whatever
> that is.  (That way, we keep this script using well known and otherwise
> tested code).
I tried also with the code of setpassword without success as I wrote in 
my other email on this thread what maid the password change succeed for 
the AES stuff is the fact that I used -s path_to_smb.conf when the 
database is not located in the default path.


More information about the samba-technical mailing list