samba 4 problems...

Andrew Bartlett abartlet at
Sun Nov 22 20:12:33 MST 2009

On Thu, 2009-11-19 at 11:30 -0200, Gilberto Nunes wrote:
> Hi folks
> I deploy a Ubuntu Server 9.10 and compile samba 4 from sources...
> I hava success to create a AD Domain and login into domain.
> But when I run ads.msc, I get Access Denied and get this message on
> console (I run samba -i -d 99 -M single):
> Kerberos: TGS-REQ Administrator at SELB.COM from for
> cifs/ at SELB.COM [renewable, forwardable]
> Kerberos: Searching referral for
> Kerberos: Returning a referral to realm COM for server
> cifs/ at SELB.COM that was not found
> Failed find a single entry for
> (&(objectClass=trustedDomain)(|(flatname=COM)(trustPartner=COM))): got 0
> Kerberos: hdb_samba4_fetch: could not find principal in DB
> Kerberos: Server not found in database: krbtgt/COM at SELB.COM: no such
> entry found in hdb
> Kerberos: Failed building TGS-REP to
> Somebody knows what is wrong?

The problem is that we do not have an implementation of 'DFS' in Samba4.
As such, the DFS lookup to find a domain controller fails (it is trying
to open a CIFS connection to administer the policy files), and gets this
odd result.

Andrew Bartlett

Andrew Bartlett                      
Authentication Developer, Samba Team 
Samba Developer, Cisco Inc.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the samba-technical mailing list