packet_* => tstream glue
Volker.Lendecke at SerNet.DE
Wed Nov 4 15:54:22 MST 2009
On Thu, Nov 05, 2009 at 09:47:53AM +1100, Andrew Bartlett wrote:
> Sure - as I said, where they represent the send() and recv() of packets,
> it makes a lot of sense. But where there is no longer a resonable
> mapping to the concept of send() and recv() as understood in unix
> systems programming then the name is no longer a good choice.
There are tons of functions in Samba4 as well where the
_send/_recv pair represents a whole set of computations
(both sending and receiving stuff) done asynchonously. Just
look at all the composite functions that are the basis for
our current tevent_req stuff.
This convention is around now for many years and has really
sunk in. It's a bit late to change now, sorry.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
More information about the samba-technical