[Fwd: samba3-3.3.4-39 not joining to ADS]

Andreas Schneider mail at cynapses.org
Mon May 25 11:41:10 GMT 2009

On Monday 25 May 2009 08:31:22 Rajeesh Kumar wrote:
> I'm unable to connect to ADS after upgrading to Samba 3.3..3.  This was
> working fine earlier.

I think the way you use the net binary worked with *older* Windows versions.

> I'm getting error message "failed to connect to AD: Malformed
> representation of principal" while joining domain.
> [root at pstand2 etc]#  net ads  join -U blr.admin at HCLT.CORP.HCL.IN -d1

-U expects normally only the username name, without the domain name. I guess 
it worked with older Windows server version but since Windows 2008 we have to 
guess the realm and append it to the username.

To specify the domain you should use -W or don't use it if you join the same 

I'm not able to test this anymore.


	-- andreas

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
Url : http://lists.samba.org/archive/samba-technical/attachments/20090525/07589d89/attachment.bin

More information about the samba-technical mailing list