Samba4 NetLogon Directory ERROR!

Sassy Natan sassyn at
Mon May 4 11:05:05 GMT 2009

Sorry for the late replay - I was a little bit sick - maybe I have a swine
flu :-)
10x for everyone who replied:

*Matthieu here is my smb.conf:* [globals]
        netbios name    = DC
        workgroup         = home
        realm                = home.local
        server role         = domain controller

        path = /var/lock/sysvol/home.local/scripts
        read only = no

        path = /var/lock/sysvol
        read only = no

I'm using linux Debian Lenny AMD64 version.

I also Using OpenLDAP: slapd 2.4.15 as my backend for samba4.


Samba3/4 sound like a cool solution, but I might stay with Samba4 since at
the moment I have no use in the file services option. I only need to run a
simple KIX32 Login script file when user is login to the domain.

My plan is to use opensolaris with ZFS as a file server (Would be better to
use Debian with BTRFS but it is not stable yet!). For this I will use the
latest Samba3 with the winbind option. I still not sure what is the best
configuration for this, since during my tests I notice there are many
options to achieve this.

I already configured Kerberos with lib_nss_ldap and pam_krb5 on my
opensoalris machine, but I need to do more research with RID option of
winbind, or maybe the RFC2307 option now after Andrew gave us a full
Microsoft Schema (UID,GID, LoginShell, UnixHomeDirectory etc....)

I think having the UID and GID inside the Active Directory is probably the
best option, but I still not sure how the SID->UID mapping will work out.

Not sure yet if I will use the RID option or maybe I will give it a try with
rfc2307 option


What's the path of the netlogon share?

path = /var/lock/sysvol/home.local/scripts

What start script are you using?

I using Kix32 (

What distro are you working with?

I used Debian Linux Lenny amd64.The best one to my option.

*For All:*

I have notice in the last few days that the OpenLDAP crash after trying to
resolved the SID for a user. I still trying to figure out what was the
problem. But maybe I should upgrade to the new version 2.4.16.

One more thing is that when creating user using ADUC the user is not added
automatically to the Domain Users. This seems to be a clean list. It did
worked in Alpha4 so something went wrong with the new schema.

Last thing is that I can't change a user password using the command line. It
says the flowing:

Dev:/var/log# net password set -UAdministrator%password sassyn
Enter new password for account [HOME\sassyn]:
net_password_set: Connection to SAMR pipe of PDC of domain 'HOME' failed:
return code = -1

Sniffing this using tcpdump doesn't give me any idea. Maybe some one will
have a starting point.

Thanks for the help

And Thanks for giving me the option to help the SAMBA Project.



On 5/2/09, Stefan (metze) Metzmacher <metze at> wrote:
> Sassy Natan schrieb:
> > Anyone?
> >
> > On Thu, Apr 30, 2009 at 5:23 PM, Sassy Natan <sassyn at> wrote:
> >
> >>  Dear Group
> >>
> >> One quick question:
> >>
> >> I have being testing Samba4 (Alpha7) with the Full Microsoft Active
> >> Directory Schema.
> >> This seems to work pretty good, but there is one issue I noticed:
> >>
> >>  if I add some files to the NetLOGON Directory - the files being deleted
> >> after I restart the server/service.
> >>
> >> I used this to put there my login scripts (KIX based scripts) and every
> >> time I do restart I need to copy them back.
> What's the path of the netlogon share?
> What start script are you using?
> What distro are you working with?
> metze

More information about the samba-technical mailing list