Samba-3.3.4 Challenges

Volker Lendecke Volker.Lendecke at SerNet.DE
Sun May 3 18:29:16 GMT 2009

On Wed, Apr 29, 2009 at 06:28:33PM -0500, John H Terpstra - Samba Team wrote:
> Hi,
> Samba 3.3.3 on Centos 5.3 has problems with profile acls on the profiles
> share, so today I updated to samba 3.3.4.  This solves the profile acls
> problem but appears to have introduced a new bug.
> Would someone who has 3.3.4 please try the following:
> 1. Execute the following and record the values reported:
> 	net getlocalsid
> 	net getdomainsid
> 2. Change the workgroup name
> 3. stop smbd, nmbd, and winbind
> 4. delete the secrets.tdb file
> 5. Start samba daemons: smbd nmbd winbind
> 6. Reset the original domain sid using:
> 	net setdomainsid S-1-5-21-xxxxxxxxxxx-xxxxxxxxx-xxxxxxxxx
> per the values obtained from 'net getdomainsid'
> The error message is:	"Cannot fetch local SID."
> I am requesting validation to make sure this is not an isolated problem.
> I'll file a bug report if someone can confirm this is not an isolated issue.

Just tried that, worked fine for me. The part that does not
work after just doing a "net setdomainsid" is the "net
getdomainsid", because that also tries to retrieve the SID
under the netbios name. If you also do a "net setlocalsid"
to the same SID you did the "net setdomainsid" for, you
might have better success.

And, looking at the order of 5. and 6.: This is wrong. smbd
will already have created a SID for you, and changing the
sid under its feet is nothing smbd appreciates.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :

More information about the samba-technical mailing list