talloc -- Eureka*
rusty at rustcorp.com.au
Wed Jul 29 20:04:17 MDT 2009
On Wed, 29 Jul 2009 04:22:31 pm Sam Liddicott wrote:
> * tridge wrote, On 29/07/09 07:37:
> > Hi Sam,
> > > Perhaps we'll call it talloc_sticky_reference and
> > > #define talloc_slippy_reference _talloc_reference
> > > #define talloc_reference talloc_reference_is_too_dangerous_for_you
> > no, please just the function you want by a new name and don't do
> > anything to the old call.
> ok... but the old name is misleading. People will use it thinking that
> they don't need a sticky reference (whatever that is!!) and then get a
> nasty surprise.
> While we don't want people to eagerly:
> neither do we want people writing fresh new code to chose the old
> function, the one with unpredictable side effects (which will now be
> talloc_free failing on multiple "old" references).
How about: talloc_attach/detach or talloc_connect/disconnect?
A completely new namespace is far clearer, esp. if we're going to deprecate
the old ones.
More information about the samba-technical