Python scripts on SAMBA4 - Alpha 8

Fri Jul 10 15:03:52 MDT 2009

I am testing on SLES 9, which has Python 2.3 installed by default.  SAMBA 4 does not like this version
for some reason so I compiled and installed version 2.6.  I then compiled SAMBA 4 and everything
compiles fine with the build recognizing "/usr/local/bin/python" and "/usr/local/lib/python2.6".
After the compile, I try to run the ./setup/provision script and I always get:

Fatal Python error: Interpreter not initialized (version mismatch?) Aborted.

I also noticed that the Python script files have "/usr/bin/python" set instead of "/usr/local/bin/python".
Regardless, I have changed the script header to point to the correct python but still get this error.
I have also un-installed the default python2.3 from SLES 9 and then re-compiled python2.6 and
re-installed it.  I also re-compiled SAMBA 4 but still get this error.
I have set the PYTHONPATH environment to "/usr/local/samba/lib/python2.6/site-packages" but
that does not help either.

Any ideas what I am missing/doing wrong??


NOTICE - This communication may contain confidential and privileged information that is for the sole use of the intended recipient. Any viewing, copying or distribution of, or reliance on this message by unintended recipients is strictly prohibited.  If you have received this message in error, please notify us immediately by replying to the message and deleting it from your computer.

More information about the samba-technical mailing list