Test for schemaUpdateNow

Anatoliy Atanasov anatoliy.atanasov at postpath.com
Wed Jul 8 08:57:25 GMT 2009

Hi Metze, 

I edited the test so each LDAP call is on different connection and I am not sending schemaUpdateNow command. 
I run it against Windows 2003 and Samba4 not in "-M single" mode.
The result is that the test failed against Samba and passed against Windows 2003. 


> -----Original Message-----
> From: Stefan (metze) Metzmacher [mailto:metze at samba.org]
> Sent: Tuesday, July 07, 2009 18:07
> To: Anatoliy Atanasov
> Cc: samba-technical at samba.org
> Subject: Re: Test for schemaUpdateNow
> Hi Anatoliy,
> > What did you run to verify that schemaUpdateNow works only in single
> process model, I use make test TESTS=ldap to run the test.
> I didn't run anything. dsdb_make_schema_global() operates on a global
> variable and can't work with the fork model.
> > I also tried:
> > self.ldb = Ldb(host, credentials=creds, session_info=system_session(),
> lp=lp)
> >
> > After each self.ldb.add_ldif(ldif) to get a new Ldb connection and it
> worked just the same
> Also against Windows?
> metze

More information about the samba-technical mailing list