Test for schemaUpdateNow

Anatoliy Atanasov anatoliy.atanasov at postpath.com
Tue Jul 7 13:23:03 GMT 2009

Hi Metze, 

What did you run to verify that schemaUpdateNow works only in single process model, I use make test TESTS=ldap to run the test.

I also tried: 
self.ldb = Ldb(host, credentials=creds, session_info=system_session(), lp=lp)

After each self.ldb.add_ldif(ldif) to get a new Ldb connection and it worked just the same


> -----Original Message-----
> From: Stefan (metze) Metzmacher [mailto:metze at samba.org]
> Sent: Tuesday, July 07, 2009 15:38
> To: Anatoliy Atanasov
> Cc: abartlet at samba.org; samba-technical at samba.org
> Subject: Re: Test for schemaUpdateNow
> Anatoliy Atanasov schrieb:
> > Hi List,
> >
> > This is the test for schemaUpdateNow command.
> > The test consists of three steps:
> > - create a schema class - test-classXXX(unique number) with unique OID
> > - call schemaUpdateNow
> > - create an object called objXXX with objectClass: test-classXXX
> > - delete the object
> >
> > In order the test to be real it should fail without the
> "schemaUpdateNow" command right, so I comment it and run it against Samba
> and Windows 2003. It turned out that it failed against Samba but succeeded
> against Windows.
> > I reproduced the scenario using ADSIEDIT against Windows 2003 and in
> this case I had to call "schemaUpdateNow" to be able to create the object.
> So I get different behavior between ADSIEDIT and the test. I suspect
> Windows 2003 to update the schema automatically. I think the next step
> will be to write to Microsoft WSPP program to see if they can clear things
> out.
> Could it be that it matters, if both operations operate on the same ldap
> connection or not?
> Also with samba it only works in the single process model...
> metze

More information about the samba-technical mailing list