Problem with samba 4 on Mac OS X 10.5.6

Piotr Buliński bulinskp at
Tue Jan 6 17:19:58 GMT 2009


I have a problem with making samba 4 ( fresh sources from git ) on Mac  
OS X 10.5.6.
I have similar problem like described here:

but mine is:
Compiling ../lib/tevent/pytevent.c
Linking bin/python/tevent.dylib
Linking bin/shared/libdcerpc_atsvc.dylib.0.0.1
Undefined symbols:
   "___progname", referenced from:
       ___progname$non_lazy_ptr in heimdal_roken.o
ld: symbol(s) not found
collect2: ld returned 1 exit status

I've tried patching source with patch from:
with combination of function from crt_externs.h in /usr/includes/
There is something like:
extern char ***_NSGetEnviron(void);
extern char **_NSGetProgname(void);

I've tried, but it gives me nothing.

Do you have any idea why it happens?
What is the status of using external heimdal libraries with samba4?
"./configure --help" said that it is experimental,
[--enable-external-heimdal Enable external heimdal libraries  
but maybe it could be solution. I don't have idea how to make samba  
with external heimdal, so any help with this will be much appreciated.
Piotr Buliński
Warsaw University of Technology

More information about the samba-technical mailing list