talloc -- Eureka*
rusty at rustcorp.com.au
Mon Aug 3 17:25:25 MDT 2009
On Thu, 30 Jul 2009 10:22:33 pm Sam Liddicott wrote:
> * Rusty Russell wrote, On 30/07/09 03:04:
> > On Wed, 29 Jul 2009 04:22:31 pm Sam Liddicott wrote:
> >> While we don't want people to eagerly:
> >> s/talloc_slippy_reference/talloc_safe_reference/
> >> neither do we want people writing fresh new code to chose the old
> >> function, the one with unpredictable side effects (which will now be
> >> talloc_free failing on multiple "old" references).
> > How about: talloc_attach/detach or talloc_connect/disconnect?
> > A completely new namespace is far clearer, esp. if we're going to deprecate
> > the old ones.
> This is true; I take the view that the current talloc audience is
> miniscule compared to what it will be; and so for the new users the old
> namespace is new and can sensibly be applied to the new behaviour.
Talloc has been around for years (I gave a presentation on it three years
ago, and it was old then). Not sure it will suddenly take off now.
I don't find anything special about the *reference names, so just pick
something equally good.
More information about the samba-technical