One issue on samba-3.0.32 version

lanttor lanttor.g at
Thu Apr 9 05:28:58 GMT 2009


I cross-compile samba-3.0.32 for powerpc platform, I build it successfully
and run the smbd on powerpc platform, but I meet the issue when I run
smbclient -L "ip_of_powerpc_platform" from host.

(1) The log.smbd on powerpc platform is:

[root@/]# cat /usr/var/log.smbd
[1970/01/01 00:05:31, 0] lib/util_sec.c:assert_gid(119)
  Failed to set gid privileges to (-1,99) now set to (0,0) uid=(0,0)
[1970/01/01 00:05:31, 0] lib/util.c:smb_panic(1633)
  PANIC (pid 441): failed to set gid
[1970/01/01 00:05:31, 0] lib/util.c:log_stack_trace(1737)
  BACKTRACE: 15 stack frames:
   #0 smbd(log_stack_trace+0x26) [0x801f7d30]
   #1 smbd(smb_panic+0x62) [0x801f7e1c]
   #2 smbd [0x801fc1d2]
   #3 smbd(set_effective_gid+0x12) [0x801fc1ee]
   #4 smbd [0x800e85c2]
   #5 smbd(set_sec_ctx+0x152) [0x800e88e0]
   #6 smbd(change_to_user+0x50e) [0x800e00f6]
   #7 smbd [0x800f731a]
   #8 smbd(make_connection+0x530) [0x800f7d86]
   #9 smbd(reply_tcon_and_X+0x27e) [0x800cb100]
   #10 smbd [0x800f4102]
   #11 smbd(smbd_process+0x326) [0x800f4a5a]
   #12 smbd(main+0x87e) [0x80278308]
   #13 /lib/ [0x803c02c8]
   #14 smbd [0x80099206]
[1970/01/01 00:05:31, 0] lib/fault.c:dump_core(181)
  dumping core in /usr/var/cores/smbd

(2) the /etc/samba/smb.conf is :

dns proxy = no
workgroup = WORKGROUP
interfaces = eth0 eth1
security = share
log level = 1                      # Default is 0
max xmit = 65535

comment = Public stuff
path = /share
public = yes
writeable = yes
browseable = yes
printable = no

(3) My test operation is:
$ smbclient -L (the samba server on powerpc board)
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.32]
Receiving SMB: Server stopped responding
tree connect failed: Call returned zero bytes (EOF)

Note: if I set smb.cnf: security = root, it could work, but seem slowly.

(4) My samba cross-compile build step for powerpc platform is  as follows:
 SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes linux_getgrouplist_ok=yes ./configure
--prefix=%{_prefix} --host=$CFGHOST --build=%{_build} --target=$CFGHOST
--with-sendfile-support --disable-cups

I tried to build and run Samba 3.0.34 version based on above steps, but meet
the same result.

Could anyone give some help for that Thanks!

View this message in context:
Sent from the Samba - samba-technical mailing list archive at

More information about the samba-technical mailing list