Error joining SLES 10 SP2 to Windows Domain: "Improperly formed account name"

Augusto Alvarez augusto.alvarez82 at
Thu May 29 20:20:06 GMT 2008

Hello everyone,

I've recently installed a new machine with *Suse Linux Enterprise Server SP2
* (released a few days ago) and *trying to join that machine to a Windows
Active Directory* I get the following error: "*Failed to join domain:
Improperly formed account name*".

It's very strange since I could actually join a SLES 10 SP1 to the same
domain a few weeks ago when I was testing the OS, but when I try using the
SP2 version and *SAMBA version* *3.0.28-0.5* this error appears*.*
 The *steps* involved were the following:
1. Edit /etc/krb5.conf following this guide (spanish):
2. Run kinit administrator at MYDOMAIN.ACOM
3. Insert administrator password. Logon OK. I can verify it on my domain
controller that there's a success audit for administrator logon.
4. I run "*net ads join -S  -U Administrator*", insert
Administrator password and I get: "*Failed to join domain: Improperly formed
account name*".
If i insert a wrong password, the message of failure login appears instead
of the previous message

 I try using net ads join several ways: trying different users, CAPS on the
domain name, etc etc. I tried using Yast configurations on SAMBA. But they
all end up on the same error.

 Any ideas???



More information about the samba-technical mailing list