net rpc join failed with 2008 server

feroz ahmed feroz.samba at
Sun Mar 23 13:33:42 GMT 2008

Dear Samba Team,

Please refer the following link.

I guess currently we access "\PIPE\lsarpc"  as anonymous user.

As it has been mentioned in the above link,
" Anonymous access to this pipe is removed by default on Windows Vista SP1
and Windows Server 2008."
I guess this is the reason why im getting  the followin error when i try to
do "net rpc join"

  cli_rpc_pipe_open: cli_nt_create failed on pipe \lsarpc to machine


For detailed logs please refer the attachment in bugzilla for the
bug bug#5328.

Forwarded conversation
Subject: net rpc join failed with 2008 server

From: *feroz ahmed* <feroz.samba at>
Date: Wed, Mar 19, 2008 at 12:22 PM
To: samba-technical at

When i run "./net rpc join -U administrator" I'm getting error "Unable to
find a suitable server".

I have logged this bug in bugzilla with bug #5328. Logs and smb.conf
are created
as an attachment in bugzilla.

In fact with 3.0.28a I'm able to join 2003 server by using "./net rpc join
-U administrator" command with out any problem.

Also I'm able to join 3.0.28a to active directory. (./net ads join -U
administrator" is success)

Any help in this regard will be appreciated.

From: *Andrew Bartlett* <abartlet at>
Date: Wed, Mar 19, 2008 at 12:27 PM
To: feroz ahmed <feroz.samba at>
Cc: samba-technical at

 This would be expected, if the 2008 server isn't running netbios.

Andrew Bartlett

Andrew Bartlett
Authentication Developer, Samba Team 
Samba Developer, Red Hat Inc.
From: *feroz ahmed* <feroz.samba at>
Date: Fri, Mar 21, 2008 at 11:23 AM
To: Andrew Bartlett <abartlet at>
Cc: samba-technical at

Dear Andreas,

I checked the status of service "TCP/IP NetBIOS Helper" It is running.

I reinstalled 2008 server and tried to join 3.0.28a to 2008server but
getting the same problem.

*Guenther Deschner* <gd at> requested me to run "net rpc join" with
-S option, this too didn't worked.

I have shared the logs while running "net rpc join"-S option in bugzilla.
-------------- next part --------------
Version: GnuPG v1.4.7 (GNU/Linux)


More information about the samba-technical mailing list