Testing samba4

Matthias Dieter Wallnöfer mwallnoefer at yahoo.de
Wed Mar 12 18:49:34 GMT 2008

Matthieu PATOU schrieb:
> Dear all,
> A few days ago I decided to test Samba4, so I downloaded a recent 
> snapshot (~2 weeks ago) with
> rsync -avz samba.org::ftp/unpacked/samba_4_0_test samba4.
> I followed the howto from and everything is mostly working.
> My setup is simple: 1 server and a couple of windows XP pcs and a 
> couple of users.
> After configuring Group policy from the mmc I started to notice this 
> message:
> WARNING: probable memory leak in ldb /usr/local/samba/private/sam.ldb 
> - 36744 blocks (startup 776) 1085698 bytes
Maybe here you should provide some additional information. Probably a 
wireshark trace could be useful or a smbd log with a high debug level.
> And a couple of other about hklm.db
It seems, that you have some problems with the registry backend. Since 
it isn't finished yet (there are some open bugs in bugzilla), also here 
some type of log could be useful. So maybe the problem is known.
> I haven't been successful at setting up my Samba4 installation as a 
> domain browser, as a result I am unable to see the samba server in the 
> network neighbourhood, it still accessible if you enter the ip address 
> or dns server name.
> I try to play with this parameters :
>         local master    = yes
>         preferred master = yes
>         wins support    = yes
> But the server doesn't seems to participate in the election of domain 
> or local browser.
This has to do with the lack of NetBIOS browsing 
> And the biggest problem is that I need to add the users in /etc/passwd 
> and /etc/shadow if I want the windows users to be able to access to 
> share disk.
> I spent all the day today to try to configure the bultin ldap server 
> so that the Linux server could authenticate against samba4's ldap 
> server. But so far I have been unsuccessful: I am not able to extend 
> the schema so I can also store Unix information (uid, gid, home ...) 
> in the LDAP. I tried to install ad4unix schema, but first I needed to 
> modify quite heavily the schema, and then I get message from the smbd 
> process :
> ldb: Unable to load modules for /usr/local/samba/private/sam.ldb: 
> partition_init: initialising backend for 
> CN=Schema,CN=Configuration,DC=eurocopter,DC=ru failed: 
> schema_fsmo_init: failed to load attriute definition: 
> CN=msSFUNSMAP-Field-Position,CN=Schema,CN=Configuration,DC=eurocopter,DC=ru:WERR_DS_NO_MSDS_INTID 
> I am asking myself if someone had an idea of a ldif file that I could 
> import in my LDAP schema in order to add support Unix account, and I 
> am also wondering if someone tried to do authentication against 
> samba4's LDAP and if so can he throw me some clues ?
At the moment this doesn't work how it should 
(https://bugzilla.samba.org/show_bug.cgi?id=4911). The authentication 
for UNIX should be handled by Samba 4 Winbind some day, which is under 
>  Regards
> Matthieu PATOU

More information about the samba-technical mailing list