CTDB configuration question

Collins, Kevin [Beeline] KCollins at chevron.com
Fri Jun 27 21:17:19 GMT 2008

I have now configured both CIFS and NFS with CTDB and it is working to a
certain extent:

I have an NFS export node 0 mounted on a client.

On the client, I start a copy from the mount.

I run 'ctdb disable -n 0' from one of the nodes. I use 'ctdb status' and
'ctdb ip' to see that node 1 has taken over - my copy continues as

I run 'ctdb enable -n 0' from one of the nodes. The copy stops and hangs
for about 5 minutes before resuming. This obviously seems to be
unexpected behavior. Both nodes are configured the same.

In /var/log/messages on both systems (at startup) I was seeing:

rpc.statd[6101]: statd: failed to bind to outgoing port, 596
falling back on randomly chosen port 

I was thinking it might be a privileged port issue since the process is
running as user "rpcuser" and the port is less than 1024. I changed the
port to 4596, but I still see:

statd: failed to bind to outgoing port, 4596        falling back on
randomly chosen port

However, I just noticed that on node 0 I see this message every time
statd restarts (via the enable), but I only see it on node 1 at the
initial startup of statd (i.e., 'service ctdb start').

I have confirmed (with lsof) on both nodes that the port is not in use.

Any thoughts?



-----Original Message-----
From: samba-technical-bounces+kcollins=chevron.com at lists.samba.org
[mailto:samba-technical-bounces+kcollins=chevron.com at lists.samba.org] On
Behalf Of Collins, Kevin [Beeline]
Sent: Thursday, June 26, 2008 8:28 AM
To: ronnie sahlberg
Cc: samba-technical at lists.samba.org
Subject: RE: CTDB configuration question

Excellent - thanks! 

-----Original Message-----
From: ronnie sahlberg [mailto:ronniesahlberg at gmail.com] 
Sent: Wednesday, June 25, 2008 7:40 PM
To: Collins, Kevin [Beeline]
Cc: samba-technical at lists.samba.org
Subject: Re: CTDB configuration question

On Thu, Jun 26, 2008 at 1:21 AM, Collins, Kevin [Beeline]
<KCollins at chevron.com> wrote:
> Ok, thanks. Do you have any suggestions on the other questions I had?
> Additionally, if I am using the first doc, then where is
> STATD_SHARED_DIRECTORY being used? It isn't being passed to the statd
> command that I can tell...

It is used by

More information about the samba-technical mailing list