libsmbclient - setxattr sometimes corrupts conext

Henrik henke at
Thu Jan 10 12:15:57 GMT 2008

10 jan 2008 kl. 02.31 skrev Derrell Lipman:

> On Jan 9, 2008 2:23 PM, Henrik <henke at> wrote:
> Hello list,
> We are using samba 3.0.28 and we noticed some weird bugs with the
> smbc_setxattr function.
> Worth of mentioning is that on our contexts we use:
> smbc_option_set( pSmbContext, "full_time_names", 1 );
> It looks like setting time values somehow corrupt the context, so that
> we can't set ACL using names. Somehow it works if we set ACL using  
> SIDs.
> This has been tried on several paths, many times, many files/
> directories after each other, same result every time.
> Hi Henrik,
> Please post all of this as a new bug, and I'll look at it.  Sounds  
> like an oversight in implementation and "should" (always the  
> operative word) be easy to fix.

BTW I've noticed that you can't change the MODE on files/folders to  
0x00 with smbc_setxattr. So there is no way of removing an attribute  
if you do not replace it. Is this also a bug or?
If so, I'll post a new one.


More information about the samba-technical mailing list