[PATCH] Add variable to define if a share should be hidden.

David Collier-Brown davecb at sun.com
Tue Feb 26 22:47:41 GMT 2008

  Well, it would be the most intelligible name yet!

I'll vote 1+ for that.


Andrew Bartlett wrote:
> On Tue, 2008-02-26 at 16:04 -0500, David Collier-Brown wrote:
>>Andrew Bartlett wrote:
>>>On Tue, 2008-02-26 at 09:51 -0500, David Collier-Brown wrote:
>>>>A janitorial question: are not the variables the opposites
>>>>of each other, so browseable = no means the same as hidden = yes?
>>>> If so, and if someone created a share called "foo$", then we
>>>>could set the variable by default, and report it in testparm
>>>>as whichever of browseable = no or hidden = yes makes sense.
>>>> Otherwise we risk creating two disjoint variables with 
>>>>overlapping semantics, which will look bizzare to anyone
>>>>trying to figure out which to use... and they they'll get it
>>>I still think that having an option for 'actually hide this' and another
>>>for 'tell the client to hide this' is asking for trouble.  
>>  At the pure semantic level, calling this one "mark as hidden"
>>disambiguates them somewhat...
>>  The possible confusion is a concern to me, but it's similar to
>>having a way to not serve files and also a way to mark 
>>them "tell the client to hide this".
> I actually think that (tell client to hide share) should be the option
> name.  Anything else makes it sound like an inverse alias for
> 'browseable'.
> Andrew Bartlett

David Collier-Brown            | Always do right. This will gratify
Sun Microsystems, Toronto      | some people and astonish the rest
davecb at sun.com                 |                      -- Mark Twain
(905) 943-1983, cell: (647) 833-9377, home off: (416) 223-5943 
(800) 555-9786 x56583, bridge: (877) 385-4099 code: 506 9191#

More information about the samba-technical mailing list