[Samba 4] Access to GPO failed

Son Nguyen sonnh at saigontech.edu.vn
Mon Dec 8 10:50:09 GMT 2008

Kenneth MacDonald wrote:
> On Mon, 2008-12-08 at 10:37 +0700, Son Nguyen wrote:
>> Hi all,
>>     I've just finished testing this feature this morning with new version.
>> version.h: 
>> #define SAMBA_VERSION_GIT_COMMIT_DATE "Sun Dec 7 21:30:36 2008 +0100"
>> #define SAMBA_VERSION_STRING "4.0.0alpha6-GIT-e3eb94e"
>> Running samba in single mode. Command start:
>>     * samba -i -M single
>>     * samba -M single
>>  In these two cases, Windows client can join domain success but cannot 
>> access Group Policy Editor from dsa.msc.
>>     * The error message in client is the same as the older:
>>           o Fail to open the Group Policy Object. You may not have
>>             appropriate rights.
>>             Details:
>>             The network path was not found.
>>     *  From windows client, I can access to the //dc.domain/sysvol success
>>     * The below is smb.log when I run samba in debug level 10
>>       (samba -M single -d 10)
>> Do you have any ideas for me to pass this step. I really want to test 
>> domain policy but I stuck in this step for more than 2 weeks.
> Can you access //dc.domain/sysvol/Policies ?  Can you create directories
> in there?

Yes, I can. When access //dc.domain/sysvol/Policies folder with 
administrator account (I have not tested with other accounts), I can 
create files and folders
> When you create a GPO, the GPT (Group Policy Template) is created
> in //dc.domain/sysvol/Policies/{GUID-OF-GPO}/

When I create a new GPO, the will be a new folder named {GUID-OF-GPO} in 
Policies folder. The contain of this folder as below:

    * GTP.ini:
    * Machine: empty folder
    * User: empty folder

> Cheers,
> Kenny.
The attachment is a archive file for a new folder was generated when I 
create new GPO.
The same error message was appeared when I try to edit the Default 
Domain Policy.
I'm looking forward for your response.

Son Nguyen
-------------- next part --------------
A non-text attachment was scrubbed...
Name: {6A14EE8D-E6AF-43DF-9F01-79F5EE7D2AFB}.rar
Type: application/octet-stream
Size: 358 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba-technical/attachments/20081208/d0492315/6A14EE8D-E6AF-43DF-9F01-79F5EE7D2AFB.obj

More information about the samba-technical mailing list