Samba3 + samba4 + others

ogy_hpower ogy_hpower at
Wed Aug 20 00:48:07 GMT 2008

Hi Andrew;

Succesfully i can joint samba 3 in the samba 4.
I have some question here; i cannot wbinfo -g to resolv the group. But succesfully for wbinfo -u.
Do you have any idea? I have the result for the samba3 on the winbind log. Can check it for me? I fully not understand what it's meant.


Log.winbind at samba3:

***[2008/08/19 15:28:03, 1] nsswitch/winbindd_util.c:trustdom_recv(229) Could not receive trustdoms
***[2008/08/20 08:46:23, 1] nsswitch/winbindd_ads.c:enum_dom_groups(324) enum_dom_groups: No groups found

----- Original Message ----
From: Andrew Bartlett <abartlet at>
To: ogy_hpower <ogy_hpower at>
Cc: samba-technical at
Sent: Monday, 11 August, 2008 7:41:29 AM
Subject: Re: Samba3 + samba4 + others

On Wed, 2008-08-06 at 04:17 +0000, ogy_hpower wrote:
> Hi all,
> For smb.conf at samba 4 i cannot run all setting from samba 3.
> So here i would like to use the samba 3 as the files server and samba 4 as the dc.
> 1) I try to bind with the server to collect user; it is fail.
>     -run wbinfo -u or -g error looking domain.
>     -time setting is correct.
>     -samba 3 is the member server of the samba 4 using 'net ads join'
>     -when user want to access the server it prompt the password.
>     -did somebody have try this before?

Which version of Samba3 is this?

I have tried this in the past, but sadly it is not yet part of our
regular testsuite.  (I had hoped that the 'franky' build system work
might advance that). 

> 2)I'm making shares folder from win2k3 pc.
>     -pc already joint the samba domain
>     -shares already set the security
>     -when i check the effective permission; it display 'windows cannot calculate the permission for $USER'.
>     -can this problem be solved?
> 3)I have 1 xp pc with current name 'jojo'
>     -i can joint the pc with my requested name like 'test-1' to samba4
>     -i can browse the pc under my network with 'test-1'
>     -but under the domain tree;under dsa.msc tools i see the computer was joint under old name 'jojo'; when i check the details the dns-domain name is correct 'test-1'
>     -is it have any way to correct this? after i'm doing rejoint back; it still pointed the old name to the tree.

So you a renaming the machine during the join?

I've noticed a very odd behaviour of windows in the past, that the
account is first created, then renamed.  It seems quite likely that this
does not work properly in Samba4. 

Andrew Bartlett

Andrew Bartlett
Authentication Developer, Samba Team
Samba Developer, Red Hat Inc.

Send instant messages to your online friends 

More information about the samba-technical mailing list