[CTDB and GFS] some troubles joining domain

Ignacio Coupeau icoupeau at unav.es
Tue Jul 10 17:40:15 GMT 2007

tridge at samba.org wrote:
> Ignacio,
>> then I think that tdb is not initialized and tdb-> points nothing:
> yep, it looks like there is no secrets_init() in the "net rpc join" 
> code paths in this branch.
> The obvious fix is this:
> --- source/passdb/secrets.c     2007-05-31 05:57:51 +0000 +++
> source/passdb/secrets.c     2007-07-01 09:31:32 +0000 @@ -615,6
> +615,10 @@ uint32 last_change_time; uint32 sec_channel_type;
> +       if (!secrets_init()) { +               return False; +
> } +

worked, thanks.

Now I testing the foundry serverIron LB with 3 nodes.
- I added a static entry for the netbios name "SMB-CTDB"
- all three nodes have "netbios name = SMB-CTDB"
- the net rpc join worked (I used it in only one node because the
secrets.tdb is shared via GFS for all nodes)

For now I'm testing the LB and have some funny results:
- 2 nodes works fine:
   + if node A stops then B receive the session from client
   + if node B stops then A receive the session from client
- the node C don't involve at all: stopping A and/or B: do nothing (the 
windows client crashes).

The load balancer is well configured... but I think is a funny business
with the browsing, also some trick with the "sticky" and "translate" VIP 
properties I think.

As soon as I can fix this, I will proceed with the smbtorture.

Dr. Ignacio Coupeau
Systems and Network Services Director
IT Services
University of Navarra           http://www.unav.edu/
Pamplona, SPAIN                 http://www.unav.es/SI/

More information about the samba-technical mailing list