Compile errors with Apache2 + mod_ntlm_winbind

Scott Barnett scottb at
Tue May 23 22:57:25 GMT 2006

I'm having compile problems with mod_ntlm_winbind when I'm using Apache
2. I've reproduced the exact problem on Ubuntu and Redhat Enterprise so
hopefully this will help rule out distro specific problems, ie. it's to
do with how I'm compiling the apache source. I can't use an rpm or deb

I'm basically having a lot of problems with the compile process not
producing a .so file and then complaining that it can't copy it to the
modules/ folder. I can get it to compile if I don't map the binaries to
the correct places with the apache configure script, but only by calling
apxs directly ("make install" doesn't work).


Example 1:
- A fresh apache install with options:
Apached installed ok

- Generic mod_ntlm_winbind install:
/usr/sbin/apxs -DAPACHE2 -o -Wc,-Wall -c
/usr/local/apache2/build/libtool --silent --mode=compile gcc -prefer-pic
-pthread -I/usr/local/apache2/include  -I/usr/local/apache2/include
-I/usr/local/apache2/include  -Wall -DAPACHE2  -c -o mod_ntlm_winbind.lo
mod_ntlm_winbind.c && touch mod_ntlm_winbind.slo
/usr/local/apache2/build/libtool --silent --mode=link gcc -o  -rpath /usr/local/apache2/modules -module
-avoid-version    mod_ntlm_winbind.lo
/usr/sbin/apxs -DAPACHE2 -S LIBEXECDIR=//usr/local/apache2/modules -n
auth_ntlm_winbind -i .libs/
.libs/ //usr/local/apache2/modules
/usr/local/apache2/build/libtool --mode=install cp
.libs/ //usr/local/apache2/modules/
cp .libs/
cp: cannot stat `.libs/': No such file or
apxs:Error: Command failed with rc=65536

- Tried installing directly with apxs
[root at web02 mod_ntlm_winbind]# apxs -DAPACHE2 -i mod_ntlm_winbind.c
SH_LIBTOOL='/usr/local/apache2/build/libtool' mod_ntlm_winbind.c
/usr/local/apache2/build/libtool --mode=install cp mod_ntlm_winbind.c
cp mod_ntlm_winbind.c /usr/local/apache2/modules/mod_ntlm_winbind.c
Warning!  dlname not found in
Assuming installing a .so rather than a libtool archive.
chmod 755 /usr/local/apache2/modules/
chmod: cannot access `/usr/local/apache2/modules/':
No such file or directory
apxs:Error: Command failed with rc=65536


Example 2:
- A fresh apache install with no configure options except the module
Apache installed OK

- Generic mod_ntlm_winbind install:

- Tried using a configure option:
[root at web02 mod_ntlm_winbind]# ./configure
checking for httpd... /usr/sbin/httpd
./configure: line 2747: /usr/sbin/httpd: No such file or directory
"httpd" was installed in /usr/local/apache2/bin/httpd because that's the
default location unless you specifically map it, this should be ok to
overide with the configure option which doesn't look like it's working.

- Tried install with just apxs
/usr/local/apache2/bin/apxs -DAPACHE2 -c -i mod_ntlm_winbind.c
Installed, .c, .a, and .la in modules/

More information about the samba-technical mailing list