Automatically configuring a windows vmware guest for remote telnet administration

tridge at tridge at
Sat Jul 22 06:30:53 GMT 2006


I finally got ./ working on one of my systems. It
still isn't working on my laptop, and all attempts to diagnose it
there have failed :(

Instead, I tried running it on 'fort', which is one of the machines I
have in the build farm. It needed some tweaks to make it work though:

 1) The sample initial_setup.conf used the path 'windows-shared' but
    the tar ball uses the path windows-scripts. Easy to fix :)

 2) I had used
      export GUEST_SCRIPT_PATH="C:\\torture"
    but need instead to use 
      export GUEST_SCRIPT_PATH="C:\\torture\\"
    as otherwise I get an error about it not being a directory. (Also,
    can the directory creation be done by the script?)

 3) the win2000 image I was using used c:\WINNT as the base windows
    directory, instead of c:\WINDOWS (a hangover of the upgrade path
    it went through from an old NT install). I changed to
    use cscript.exe without the full c:\windows\system32\ path, and
    that worked fine. That should work on all systems I expect (as
    system32 should always be in the path).

 4) my vmware image had some disks which had settings which didn't
    allow snapshots. I changed their settings to fix that.

 5) my vmware image had a slightly older version of the vmware tools
    installed. I upgraded to the recently released
    VMware-server-1.0.0-28343 release and upgrade the images firmware
    and the vmware tools. That fixed that problem.

Cheers, Tridge

More information about the samba-technical mailing list