Make fails on Tru64 for samba-3.0.23

derrell at derrell at
Thu Jul 13 18:36:49 GMT 2006

"Gerald (Jerry) Carter" <jerry at> writes:

> Jeremy Allison wrote:
>> On Thu, Jul 13, 2006 at 07:20:36PM +0530, Kamanhalli, Pavan S wrote:
>>> Hi All,
>>>         I have downloaded samba-3.0.23. I ran configure with options
>>> like this,
>>> # ./configure --with-acl-support --with-smbwrapper --with-winbind. 
>>>      When I run make I am getting Unresolved symbol error,
>>> Compiling smbwrapper/wrapped.c with -fPIC
>>> Linking shared library bin/
>>> ld:
>>> Warning: Unresolved:
>>> secrets_fetch_domain_sid
>>>   Any help is appreciated.
>> Yes, don't build with smbwrapper - it is planned to
>> be removed in 3.0.24.
> And it's out-a-here !

Jerry, are you planning on moving example/libsmbclient/smbwrapper into source,
or leaving it where it is?  Leaving it in its place means no one will use it
and I won't have any additional work to do. :-) Moving it means it'll get more
testing and (hopefully) more developers helping to improve it.


More information about the samba-technical mailing list