[PATCH] Fix dependencies in ldb subsystem
jelmer at vernstok.nl
Mon Apr 3 10:55:41 GMT 2006
Tim Potter wrote:
> On Mon, Apr 03, 2006 at 02:53:47AM +0200, Jelmer Vernooij wrote:
>> Btw, it looks like torture_tdb.py contains python2.4-specific code. It
>> complained here about missing set() when run using python2.3
> Hrm. I was wondering which Python features I should use. At the moment
> there is the set stuff which requires Python 2.4 as you say, and also
> iterators which I think are Python 2.2. I was hoping to be able to say
> that the wrappers work with any of Python 2.x although there are really
> useful bits and pieces in 2.2 and above.
> Python 2.1 seems to be the oldest version on modern distros that I have
> used. What do you think?
I think it is hard to find a system with anything older then 2.2 on it.
It would imho be fair to depend on 2.4 if there's a good reason to.
I have both 2.3 and 2.4 installed, but unfortunately 'python' is a
symlink to 'python2.3'.
More information about the samba-technical