svn commit: samba r11868 - in branches/SAMBA_4_0/source/torture/rpc: .

tridge at tridge at
Fri Nov 25 00:03:29 GMT 2005


 > To be honest, what is the point of putting
 > /*
 >   Receive an schannel'ed netlogon bind
 > */
 > static void xp_login_recv_schannel(struct composite_context *creq)

With syntax color highlighting I find that having a small comment
actually does make code more readable. 

Plus in the example you give, you've said its about a bind, whereas
the function name doesn't say that, so the comment actually added some
real information. Also, I think the english sentence makes it a little
bit clearer than the abbreviations in the function name, such as
Receive instead of recv.

Finally, and perhaps most importantly, by getting into the habit of
putting at least a small comment on functions you may find that the
extra effort of putting just a few more words of explanation happens a
bit more often.

So I would prefer a small comment block even if its a trivial
one. Just be thankful I'm not an advocate of the "put a page of info
on the authors life history in front of each function" school of
programming :-)

Cheers, Tridge

More information about the samba-technical mailing list