libmsrpc function naming

Chris Nicholls skel at
Thu Jul 21 20:23:03 GMT 2005

>Consistency is pretty important here I think.  Although
>if you want to go with something like cac_LsaOpenPolicy(),
>that would be find with me.  The lack of upper case and
>_ characters can make the function name too long IMO.
>Consider cac_OpenPrinterEx() vs. cac_open_printer_ex().
>This gets more into coding style though. So choose wisely :-)
I usually prefer to use lower case and underscores. but 
cac_lsa_query_trusted_domain_info() (along with at least 3 parameters) 
is pretty scary.. a lot of function names  (at least on the LSA pipe) 
are going to be rather lengthy and there isnt much that can be done in 
the way of abbreviations.. something like cac_lsa_get_trust_dom_info 
would take a way from readability.  I agree that using upper case 
letters is the smart way to go, even if it's not my prefered coding style.


More information about the samba-technical mailing list