[Samba] Samba 3.0.10 - Error With Latest Win2K Patches

Justin Piszcz jpiszcz at lucidpixels.com
Fri Feb 11 14:24:11 GMT 2005

Just a note: It has _ALWAYS_ worked, I applied the patches on Windows 2000 
yesterday and it stopped working after that.

Perhaps a Windows 2000 problem?  Do you use Windows 2000 and have updated 
to the latest patches? *THAT* is when the error began!

Here it is:

# The global is required for all global virables.
         # We want the workgroup set to WORKGROUP.
         workgroup = WORKGROUP
         # Set the server string to describe the machine.
         server string = %h - Pentium III 500MHZ
         # Set the interface so Samba only works with the LAN.
         interfaces =
         # Make sure it only binds to this interface.
         bind interfaces only = yes
         # Set the security to user.
         security = user
         # Make sure encrypt passwords is on!
         encrypt passwords = yes
         # Increase overall throughput of samba.
         socket options = IPTOS_LOWDELAY TCP_NODELAY SO_SNDBUF=32768 SO_RCVBUF=8192
         # Set max xmit size.
         max xmit = 8192

   comment         = x
   path            = /d1/x
   writable        = yes
   valid users     = jpiszcz
   create mask     = 644

On Fri, 11 Feb 2005, Andreas Koch wrote:

> Hi Justin,
> i have also W2K and samba 3.0.8-2
> It's work fine.
> Send me please your smb.conf
> 	Andreas
> Am Freitag, den 11.02.2005, 06:20 -0500 schrieb Justin Piszcz:
>> When Microsoft released their 8-9 new patches this week, around Tuesday,
>> 02/08/05; I can no longer copy files to any of my samba shares.
>> Before Microsoft's patches, everything worked OK; I have multiple Linux
>> SAMBA servers and two separate Windows 2000 Professional SP4 machines;
>> each were patched.  Trying to connect to any of the Samba servers
>> I am running Samba 3.0.10 with Debian Sarge and kernel 2.6.10.
>> When I try to drag any file over an (explorer window) with a (samba share)
>> open it puts a circle with a (/) slash through it.  When I run xcopy
>> file.zip \\ip\share, it works.
>> 1) I can remove a directory on my Samba share.
>> 2) I can remove a file on my Samba share.
>> 3) I can make a directory on my Samba share.
>> 4) I cannot copy anything over to the Samba share (file, link or directory).
>> Has anyone experienced these problems with the latest Windows 2000
>> Professional patches? What is the recommended fix?
>> Please CC me as I am not on the list, thanks.

More information about the samba-technical mailing list